1
$\begingroup$

Given two variables A and B with 35 random data points (generated with Excel in the range of 0 to 1), we applied Analyse -> Nonparametric Tests -> Legacy Dialogs -> 2 connected Samples in SPSS and marked "Wilcoxon" as test, which should perform the the Wilcoxon signed-rank test. All over the internet you find examples of the test reporting a "Z" value. However, our report is

Teststatistics$_a$

U: -1.032$_b$

Asymp. Sig. (2-sided): .302

a: Wilcoxon-Test b: based on negative ranks

Why does the test not report a "Z" and how should we modify to obtain a "Z" rather than a "U"?

EDIT: Here's what we did and the output, and the original data is in my Google Drive.

enter image description here enter image description here enter image description here

$\endgroup$
  • $\begingroup$ What SPSS version are you using? My version 22 displays Z. But in any case you can look into SPSS algorithms (in Help) to find out how U and Z are connected. $\endgroup$ – ttnphns Jul 16 '15 at 14:12
  • $\begingroup$ It is SPSS version 22. And sadly enough, I was not able to find any mention of U in the help concerning the Wilcoxon signed Rank Test. $\endgroup$ – Skrodde Jul 16 '15 at 14:16
  • 1
    $\begingroup$ I see. Sorry for saying about U. U pertains to Mann-Whitney test. Well, back to your problem. My version is patched 22.0.0.2 Win 64bit. Visit IBM SPSS site to download patches. The "U" might probably be a lapse in the output and being really meant is Z. Can you post a small data snippet and the result in your question so that I could compare your and my figures? $\endgroup$ – ttnphns Jul 16 '15 at 14:25
  • $\begingroup$ I added a link to the data, as well as screenshots of our procedure and a screenshot of the output to the original post. Thank you for the efforts you put into this! $\endgroup$ – Skrodde Jul 17 '15 at 20:11
  • $\begingroup$ Yes, your result is correct. But "U" is a typo. My SPSS displays it as "Z". One reason may be, as I supposed, that my version is patched while yours probably not. Another reason is that the typo is only in your language of output. Try to go to Edit-Options and set to English output: will the typo persist? $\endgroup$ – ttnphns Jul 17 '15 at 21:31
0
$\begingroup$

Thanks to the suggestion of ttnphns, we were able to detect the error. It is, as a matter of fact, the German SPSS settings. Switching to English, the test immediately showed a Z value. Will now try to see whether patching the software in the German version helps.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.