0
$\begingroup$

I've come across some very odd behavior in the mgcv package in R when fitting a beta regression GAMM (using the gam function). The model(s) run normally, produce seemingly reasonable results/output; however, when you inspect the gam object, the 'converged' logical is FALSE. To make matters more confusing, when running gam.check(), it will say things such as "full convergence after 7 iterations"!!

Thoughts?

$\endgroup$

closed as off-topic by Gavin Simpson, Michael Chernick, mkt, kjetil b halvorsen, Ferdi Feb 12 at 10:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question appears to be off-topic because EITHER it is not about statistics, machine learning, data analysis, data mining, or data visualization, OR it focuses on programming, debugging, or performing routine operations within a statistical computing platform. If the latter, you could try the support links we maintain." – Gavin Simpson, Michael Chernick, mkt, kjetil b halvorsen, Ferdi
If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ In order to help you I'd need a working example of your problem, or at least the whole output of these calls. $\endgroup$ – Lucas Farias Feb 11 at 22:32
  • 2
    $\begingroup$ I suggest you contact Simon Wood, the maintainer, with a reproducible example. There was something in the latest release 1.8-27 that suggested that false failed convergence was being declared, which affected general families (which includes the betar family), and perhaps this is related to the fix? $\endgroup$ – Gavin Simpson Feb 12 at 3:04
  • $\begingroup$ Thanks, @Gavin Simpson. That was my next step, but I try not to bother maintainers until I have determined something is not a routine user error. I will touch base with him and update the thread. $\endgroup$ – MattT Feb 12 at 13:40