-1
$\begingroup$

I am trying to install RQDA, because I want to analyse some interview scripts, but I keep on getting an error message, have tried various pieces of advise but still in vain. I installed the following: install.packages(RGtk2), after installing then did this: library(RGtk2) and library(RQDA), and the latter part gives me the following: library(RQDA) Loading required package: RSQLite Error: package or namespace load failed for ‘RSQLite’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘rlang’ 0.4.0 is already loaded, but >= 0.4.5 is required Error: package ‘RSQLite’ could not be loaded In addition: Warning messages: 1: package ‘RQDA’ was built under R version 3.6.3 2: package ‘RSQLite’ was built under R version 3.6.3

I tried install RSQLite, but got the following error message: install.packages(RSQLite) Error in install.packages : object 'RSQLite' not found

install.packages("RSQLite") Installing package into ‘C:/Users/Helper/Documents/R/win-library/3.6’ (as ‘lib’ is unspecified) trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.6/RSQLite_2.2.0.zip' Content type 'application/zip' length 2275191 bytes (2.2 MB) downloaded 2.2 MB

package ‘RSQLite’ successfully unpacked and MD5 sums checked Error in install.packages : ERROR: failed to lock directory ‘C:\Users\Helper\Documents\R\win-library\3.6’ for modifying Try removing ‘C:\Users\Helper\Documents\R\win-library\3.6/00LOCK’

Now I am stuck and not sure what exactly to do to get the package working. Kindly help

$\endgroup$
  • $\begingroup$ Have a look at the RQDA page. They have detailed instructions on how to install it. Have you installed GTK+ before installing RGtk2? $\endgroup$ – Joe Mar 26 at 12:01
  • $\begingroup$ No i did not install GTK+, let me do that and will share feedback. Thanks a lot $\endgroup$ – hzhou Mar 26 at 15:00
  • $\begingroup$ I have tried install following the steps as per your instructions but still no joy, after loading the library(RQDA) I keep getting the error message:Error: package or namespace load failed for ‘RSQLite’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): Error: package ‘RSQLite’ could not be loaded $\endgroup$ – hzhou Mar 26 at 15:51

Browse other questions tagged or ask your own question.