1
$\begingroup$

When I type a left paren or any quote in the R console, it automatically creates a matching one to the right of my cursor. I guess the idea is that I can just type the expression I want inside without having to worry about matching, but I find it annoying, and would rather just type it myself. How can I disable this feature?

I am using R 2.8.0 on OSX 10.5.8.

$\endgroup$
3
  • 3
    $\begingroup$ I agree. I think R programming question would be a better fit on StackOverlfow.com than here. stackoverflow.com/questions/tagged/r $\endgroup$ Jul 29, 2010 at 2:45
  • 1
    $\begingroup$ @mbq: @JohnD.Cook: This is not a programming question. It is also not a question about a common tool of programmers. It is a question about a common tool of statisticians. That is why I asked it here. I don't mind that it was closed, though, since I received and accepted the correct answer. $\endgroup$
    – anonymous
    Jul 29, 2010 at 14:16
  • 1
    $\begingroup$ It is a question about using a computer program use; so I think you should try SuperUser. Dirk is there, so R questions will be answered in a blink of eye ;-) $\endgroup$
    – user88
    Jul 29, 2010 at 16:13

3 Answers 3

5
$\begingroup$

On OSX, go to R > Preferences > Editor and deselect Match braces/quotes

$\endgroup$
0
4
$\begingroup$

To follow on from Dirk's comment, if you don't like your current IDE, check out some of the existing discussion on R IDEs: https://stackoverflow.com/questions/1439059/best-ide-texteditor-for-r

$\endgroup$
3
$\begingroup$

Well either use a different IDE -- this is entirely a feature of the OS X app -- or try to configure the feature in question.

As for IDEs / R environments, I'm rather happy with ESS which works on every platform R works on.

$\endgroup$